Loading

ブログ

【質問4】

最近、WordPressやMovableTypeを使ったサイト制作依頼が増えてきたのですが、 どのようなサーバ環境下で利用できるのかイマイチわかりません。 サーバ環境のどのようなことを調べればWordPress等のCMSが利用できるのかわかりますか?

【回答4】
WordpressやMovableTypeなどのCMSは
それぞれ必要なプログラミング言語(PHPやPerlなど)と
データベース(MySQLやPostgreSQLなど)が必要となります。

また、プログラミング言語やデータベースの必要とされるバージョン(数字の大きなものほど新しいものになり、公開されている一番数字の大きい物が最新版になります)も考慮しなければなりません。ある程度古いバージョンでも動作しますが、セキュリティ面においてリスクがあることを理解したうえで利用しなければなりません。

代表的なCMSの例としては以下のようになります。

WordPress日本語版では以下のものが必要となります。
PHP バージョン 5.2.4以上(5.6以上推奨)
MySQL バージョン 5.0.15以上(5.5以上推奨)

MovableTypeでは以下のものが必要となります。
Perl バージョン 5.8.1以上(5.14以上推奨、5.18以上は未検証のため推奨されていません) ※
MySQL バージョン 5.0以上
※ Perl本体以外にもいくつかのPerlモジュールが必要です。詳細はドキュメントを御覧下さい。

その他のCMSにおいても、ドキュメントなどに
必要とされるプログラミング言語とデータベース、そのバージョンが記載されていますので
それぞれ確認したうえで条件を満たすサーバーをご用意下さい。

  • このエントリーをはてなブックマークに追加

PAGE TOP